Hi,
there was a compatibility issue with PDFsam Basic version 3.3.3 (and below) that was preventing it to start with Java 9. We just released PDFsam Basic 3.3.4 and with that everything should be back to normal and work as expected even if you upgrade to Java 9. We also added handy row headers to easily find the index of the added PDF files and the total number of added PDF files.
Enjoy

4 Replies to “PDFsam Basic 3.3.4 fixing Java 9 compatibility”
  1. Thank you!
    However, both this & the previous version are incompatible with Java 8 update 151 (unless this is a Windows XP issue). You need to downgrade Java 8 to update 144, otherwise PDFsam Basic exits upon clicking anything within its window (even the background).

    1. We had a couple of other users reporting and we think it’s a Java8/WinXP related issue.. we haven’t investigated but Win XP is no longer an officially supported platform by Java since 2014.

  2. PDFsam Basic 2.2.2 is working fine again with java 7/u80, the last version compatible with XP according to Oracle. I don’t use it often but it worked OK with some earlier versions of java 8. It’s not worth my time to explore further for my limited needs.

Leave a Reply

Your email address will not be published. Required fields are marked *

mode_edit
account_circle
email